OpenWrt comme AP Wifi en WPA

Je ne sais pas si je l’ai déjà dis, mais j’adore openwrt 😉

J’ai un réseau en 192.168.2.X et par un malencontreux coup du sort je suis contraint d’utiliser une carte wifi du serveur pour accéder au Grand Ternet. Je n’ai plus de wifi résidentiel donc la tablette fait la grise mine (plus d’accès au NAS 😦 )

Bref, ce soir j’ai parametré openwrt en AP WPA en suivant cette procédure, claire, concise, efficace …

  • /etc/config/network
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option gateway '192.168.2.3'
list dns '192.168.2.1'
list dns '8.8.8.8'
list dns '8.8.4.4'

config interface 'wan'
option ifname 'wlan0'
option 'proto' 'static'
option 'ipaddr' '192.168.3.1'
option 'netmask' '255.255.255.0'
  • /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel 11
option macaddr '14:e6:e4:a7:09:d2'
option hwmode '11ng'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'

config wifi-iface
option device 'radio0'
option network 'wan'
option mode 'ap'
option 'ssid' 'nom du reseau'
option encryption 'psk2'
option key 'CestlaclefWPAsupersecrete'
  • /etc/config/firewall

config zone
option name lan
option network ‘lan’
option input ACCEPT
option output ACCEPT
option forward REJECT
option masq 1

config zone
option name wan
option network ‘wan’
option input ACCEPT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1

config forwarding
option src wan
option dest lan

config forwarding
option src lan
option dest wan

  • /etc/config/dhcp
config dhcp 'wan'
option interface 'wan'
option start '200'
option limit '225'
option leasetime '12h'

Coté serveur linux j’ai eu la commande suivante à passer pour accéder aux machines de l’autre subnet

route add -net 192.168.3.0 netmask 255.255.255.0 gw 192.168.2.1 eth2

et le ping passe dans les deux sens, c’est déjà pas mal.

Reste à trouver comment faire fonctionner le discover DNLA depuis le subnet en 192.168.3.xx

TODO : j’ai entendu parler d’un igmpproxy qui semblerait correspondre … a faire

Publicités

Publié le 23 avril 2012, dans OpenWRT, et tagué , , . Bookmarquez ce permalien. 3 Commentaires.

  1. bonjour,

    je trouve votre blog tres instructif,
    j’ai moi-meme depuis peux un wr703n et je m’amuse beaucoup avec 🙂
    je l’ai bien sur deja briqué ( au bout de 2 heures) mais maintenant je maitrise
    le port serie et la console 😉 .
    je me rend compte que vous avez l’air d’etre a l’aise avec les configs reseaux du tp link ,
    moi j’ai un petit soucis avec ma config , j’ai installé dessus un lecteur de flux mp3 (pour la radio) le programme « Madplay » , le routeur est en wifi mode client pour ce connecter a mon routeur internet,
    je recois bien la music (radio via un adaptateur usb/audio)) mais je n’arrive pas a me connecter au tplink en wifi , ni en telnet ou ssh et il ne reponds pas aux ping !!! par contre si je branche un cable reseau depuis mon routeur internet cela fonctionne bien ( ip fixe du tplink en lan 192.168.1.50)
    ip fixe du wan (wifi) 192.168.1.60 , et ip de mon routeur internet 192.168.1.1 .

    si vous pouviez m’eclairer … Merci

    • Je pense qu’il faudrait que tu règles le wifi sur un subnet (ex 192.168.2.1) et le RJ45 sur un autre (192.168.1.1), sinon un ping sur le 192.168.1.1 la machine va chercher à répondre et prendra soit le wifi soit le RJ45.
      Bon j’ai briqué ma machine donc pas possible de retester, par contre je prends les liens vers le HOWTO pour unbrick la bestiolle 😉 Comme ça quand j’aurais le temps …

  2. ok je fais le test ,
    voici des liens pour debrikage , c’est pas compliqué:

    http://bluemarmot.tucristal.es/drupal/fr/node/30

    http://forums.openpilot.org/blog/52/entry-92-unbrick-wr703n-wifi-router/

    si tu as besoin d’explications n’hésite pas
    A+

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :