Instabilité de l’Arduino relié au WR703N – Part 2

Comme je l’avais dis dans mon précédent billet, j’ai des soucis de stabilité de lecture du port serie depuis le WR703N.

J’ai donc modifié le programme de lecture pour faire une fermeture puis une réouverture du port série, le problème se reproduit donc ce n’est pas la solution.

En complément j’ai modifié mon code Arduino pour allumer une led pendant la mesure, la led reste donc allumée quelques secondes avant de s’éteindre pendant la phase d’attente. J’ai bien constaté que pendant le figeage des lecture la led s’allumait et s’éteignait. L’Arduino n’est donc pas figé.

Le problème semble donc se situer au niveau du module cdc_acm ou du programme C. Sachant que le meme programme se déroule sans encombre sur mon PC Linux, je privilégie un pb module ou une spécificité à apporter à l’initialisation du port série. 

Pour le moment je n’ai pas d’idée comment avancer … si un lecteur en a … je prends

Publicités

Publié le 24 juin 2012, dans Arduino, OpenWRT, et tagué , . Bookmarquez ce permalien. Poster un commentaire.

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :